ニュー即ブログν

ニュー即ブログν
スポンサーリンク

この記事をシェアする!

PHP 5.x、本日2018年12月31日でサポート終了

この記事をシェアする!

スポンサーリンク
Photo - https://ln.newsoku.blog/2F8cFxp
Photo - https://ln.newsoku.blog/2F8cFxp
1: ニュー即@名無し 2018/12/31(月) 16:15:10.77 _USER92019年まで@1日

一方、より注目されているのはPHP 5.6のサポート終了だ。5系から7系への移行に伴い長期サポートが提供されていた5.6だが、12月31日をもって完全にサポートが終了する。しかし、12月1日時点で75.8%のユーザーがPHP 5.xを使用しているということで、早期の移行が呼びかけられている。なお、7系でも7.0については12月3日にサポートが終了したため、こちらも注意が必要だ。

【おすすめ記事!】


10: ニュー即@名無し 2018/12/31(月) 16:28:19.64 2019年まで@1日
>>1
動作環境のハードルが上がるわけか

14: ニュー即@名無し 2018/12/31(月) 16:33:49.04 2019年まで@1日

>>1
>>12月1日時点で75.8%のユーザーがPHP 5.xを使用している

仲間がたくさん居て良かった( ´∀`)
調べたら、バージョンアップは、現行バージョンを削除して
新バージョンを新規インストールすることになるらしい
24時間運用のサーバーでそんなこと簡単にできないよね

16: ニュー即@名無し 2018/12/31(月) 16:35:33.57 2019年まで@1日
>>14
サーバーをもう一台立ち上げてDNSで切り替えかな

20: ニュー即@名無し 2018/12/31(月) 16:39:08.43 2019年まで@1日
>>16
そうなのよ
でも、今使ってるVPSが昔の安い料金設定の時に契約したものなので、
新サーバーにすると、値上げされて高くなった料金プランになっちゃうの><;

22: ニュー即@名無し 2018/12/31(月) 16:42:32.38 2019年まで@1日
>>20
VPSの契約変えないならならメインサーバーのシステム更新したら
コピーサーバーから接続をそっちへ戻すという手間が必要になるけど
仕方ないと思う

25: ニュー即@名無し 2018/12/31(月) 16:47:38.58 2019年まで@1日
>>22
ああ、移行期間だけ新サーバー契約して旧設定で動かして、
現行サーバーを新設定にして、また現行サーバー運用に戻せばいいのか
なるほど、いざとなったらそうするわ
サンクス!

28: ニュー即@名無し 2018/12/31(月) 16:53:25.13 2019年まで@1日
>>14
切り替え以前の問題
PHPはバージョンごとの仕様変更がデカいから、7対応で作ってないプログラムは下手すりゃ動かない

2: ニュー即@名無し 2018/12/31(月) 16:19:47.85 2019年まで@1日
おわってるな

3: ニュー即@名無し 2018/12/31(月) 16:22:25.92 2019年まで@1日

人は記憶型と思考型に大別できる

PHPってWEB専用だろ
ほとんどの関数は互換性があるだろうから鯖管が大変なだけだろ

>array_key_first()関数

指定するキーを配列の先頭に持ってくるという意味か?

31: ニュー即@名無し 2018/12/31(月) 16:55:32.13 2019年まで@1日

>>3
ど素人は黙ってろ。
お前本当に何も知らないことに、小学生でも馬鹿にされるようなコメントするよな。

関数の名前、呼び出し方全てが違ってる。

だから3/4が移行できていない。

4: ニュー即@名無し 2018/12/31(月) 16:22:36.75 2019年まで@1日
え、まだサポートしてたの

5: ニュー即@名無し 2018/12/31(月) 16:22:43.17 2019年まで@1日
PHPもバージョン間の断絶が大きいからな
Perlみたいになってしまうのか

33: ニュー即@名無し 2018/12/31(月) 16:56:50.58 2019年まで@1日
>>5
手作りだから良い感じなものもあるのに、創業者はそれを一級の工業製品にしようと思うらしいね、

6: ニュー即@名無し 2018/12/31(月) 16:22:50.74 2019年まで@1日
レンタルサーバーのサービス提供側が更新してくれないと対応しようがないな

7: ニュー即@名無し 2018/12/31(月) 16:23:14.13 2019年まで@1日
また作り直しか…

8: ニュー即@名無し 2018/12/31(月) 16:23:24.36 2019年まで@1日
7.2から7.3に上げたら爆速になった。
サポートされなくなったAPIがあったり、5系から最新に上げるのは大変だ。
早くやっておけばいいのに・・・

9: ニュー即@名無し 2018/12/31(月) 16:27:45.49 2019年まで@1日
自己啓発の元祖だよな
なんか暑苦しそうで鬱陶しい連中ってイメージ、JC(青年会議所)とかぶる

17: ニュー即@名無し 2018/12/31(月) 16:35:58.61 2019年まで@1日
>>9
PHP文庫じゃねえよ!

【おすすめ記事!】
スポンサーリンク
【おすすめ記事!】

引用元
http://asahi.5ch.net/test/read.cgi/newsplus/1546240510/

11: ニュー即@名無し 2018/12/31(月) 16:28:35.09 2019年まで@1日
互換性無いなら上の桁からバージョン番号変えれよ

34: ニュー即@名無し 2018/12/31(月) 16:57:21.66 2019年まで@1日
>>11
もっと言って、言語の名前を変えろと。

38: ニュー即@名無し 2018/12/31(月) 17:03:15.16 2019年まで@1日
>>34
そこまでは変わらないし製品として変わったとしてデメリットもでかいだろ

12: ニュー即@名無し 2018/12/31(月) 16:29:44.85 2019年まで@1日
5.x系~7.3.x系の互換プラグインとか無いの?

13: ニュー即@名無し 2018/12/31(月) 16:30:11.69 2019年まで@1日
おれんとこなんてまだphp5.2使ってんぜ
というわけで年明けは7.3に移行するつもりでちょうど今sshいじってたとこだ

15: ニュー即@名無し 2018/12/31(月) 16:34:48.66 2019年まで@1日
php7.3に移行したら次は、HTML5.2に対応か?

18: ニュー即@名無し 2018/12/31(月) 16:37:07.99 2019年まで@1日
ウチなんてまだPHP4だぜ

19: ニュー即@名無し 2018/12/31(月) 16:37:27.14 2019年まで@1日

こういうタイミングで、何だかんだ古いけど微妙な需要のあるサイトが
消え去っていくんだろうな。

後で見たらマイナーめなレトロゲーの攻略サイトが消えてて
めんどくさかった。

21: ニュー即@名無し 2018/12/31(月) 16:39:56.42 2019年まで@1日
切り捨てるつもりが逆に切り捨てられる未来しか見えないなw

23: ニュー即@名無し 2018/12/31(月) 16:43:19.06 2019年まで@1日
このスレでNode.js使っている人に聞きたいんだが
ぶっちゃけ将来的にPHPを凌駕できる物なの?

36: ニュー即@名無し 2018/12/31(月) 17:01:56.53 2019年まで@1日

>>23
技術的に可能というのと、人が乗り換えるかというのは別。

技術的にはPHPは大したことがないし、大したことには使っていないだろうからいくらでも乗り換えできるが、node.jsは開発者のレベルが高く、やたらとバージョンの変動が大きい。

ちょっくら頑張ってプログラムしてみました程度のPHPのメインストリームにはほぼ無理。

37: ニュー即@名無し 2018/12/31(月) 17:02:19.42 2019年まで@1日
>>23
一般的なWebサイトはPHP、API部分をNodeみたいに棲み分けると思う
Nodeは非同期処理はやりやすいけど、でかいものを作るとカオスになりがち
PHPは利用人口の多さからくるシステム標準機能の整備とフレームワークが進んでる
ていうかPHPもそんなに評価高くないが

24: ニュー即@名無し 2018/12/31(月) 16:46:33.58 2019年まで@1日
75.8%も使っているのにサポート切るのか!?

26: ニュー即@名無し 2018/12/31(月) 16:49:07.94 2019年まで@1日
>>24
その内の大半が商品としてサポート切れてる説

27: ニュー即@名無し 2018/12/31(月) 16:50:51.79 2019年まで@1日
RedHat/CentOS 7.x系がphp5.4だからなー

35: ニュー即@名無し 2018/12/31(月) 17:00:41.63 2019年まで@1日
>>27
自然利用者が多いのは、5.4って事になるよな

32: ニュー即@名無し 2018/12/31(月) 16:55:46.84 2019年まで@1日
レンタルサーバーが余裕で5.1とか使ってるもんなぁ

39: ニュー即@名無し 2018/12/31(月) 17:04:09.73 2019年まで@1日

<?php3

の頃から使ってるわ。

40: ニュー即@名無し 2018/12/31(月) 17:06:07.27 2019年まで@1日
NodeはWebサーバ以外にもelectron等によるアプリ構築が出来て、PHPよりも用途が広い
PHPはバカでも扱える簡単さからくる利用人口でWeb特化
ターゲットがあまり被っていない